Free Game Research Forum | Official QuickBMS support | twitter @zenhax | SSL HTTPS://zenhax.com
It is currently Mon Mar 08, 2021 9:40 pm

All times are UTC

Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sun Jan 17, 2021 1:31 pm 

Joined: Sun Jan 17, 2021 12:19 pm
Posts: 2
Hi. I'm new here, so if this should've been posted elsewhere, let me know.

I'm having trouble running Quickbms on Linux. I'm trying to run it to exctract the "*.resources" file from Doom Eternal for modding purposes. Interestingly enough, if I run the Windows exe through Wine with the same script, all the files are extracted successfully.

Here's what I get when I run it

offset filesize filename
00230000 1119 art/tile/hell_earth/ash_chunky_h.tga
Info: algorithm 650
offset 00230000
input size 0x0000034b 843
output size 0x0000045f 1119
result 0xffffffff -1

Error: the uncompressed data (-1) is bigger than the allocated buffer (1119)
It usually means that data is not compressed or uses another algorithm

Last script line before the error or that produced the error:

The script is the one from here with no changes made to it.

What I've tried so far:
- Installing from the Arch User Repository - installs successfully, but gives this error when ran
- compiling from source code(both with and without the "-DDISABLE" flag) - same result as above. All dependencies(and then some) were installed as per the document.
- running the Linux static executables provided on the website - again, same result

I'm fine with running the Windows version since it shows no issues with Wine, but i've been researching this for the past few days and couldn't find anything useful(and I would perefer to run the native version, if possible). If anyone could help, it would be gratly appreciated.

One last thing to add, is that it seems to start creating the relevant folders, just that it fails to extract the files.

PostPosted: Wed Jan 20, 2021 10:51 am 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 12013
The oodle library is not available on Linux because there is no .so publicly released (as far as I know since Warframe is for Windows only).

While there is an unofficial open source version on github, it's not implemented in quickbms. I guess I planned to support it in the current beta but then something went wrong during the implementation and therefore I gave up. Additionally, being an old reverse engineered code, it may not cover all the features of the library.

So if there is any game with an oodle shared library publicly available (32bit is better but I suppose it's 64bit only) I think I can implement it very easily just like I did for the Windows code.
Otherwise no solutions.

PostPosted: Wed Jan 20, 2021 11:49 am 

Joined: Sun Jan 17, 2021 12:19 pm
Posts: 2
Thank you for the reply. It's unfortunate that it doesn't work, but I'll keep an eye on future updates in case it gets implemented.

PostPosted: Tue Feb 16, 2021 12:14 am 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 12013
The current beta uses the reverse engineered version of oodle.
The only requirement is an x86/x64 CPU because that code uses the SSE2 extensions.
Beta source code if you want to try:

I created a compressed oodle file with quickbms on windows and I successfully decompressed it on linux, so it works even if it may not support all the less used oodle algorithms (but even oodle itself doesn't support them since they change at every release! :D ).

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited