ZenHAX

Free Game Research Forum | Official QuickBMS support | twitter @zenhax | SSL HTTPS://zenhax.com
It is currently Fri Oct 30, 2020 12:45 am

All times are UTC




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Jul 19, 2020 11:34 am 

Joined: Fri Jan 11, 2019 12:23 pm
Posts: 9
Using HyperRipper on the main.rsb archive (forum post here: viewtopic.php?f=9&t=9178) and it spewed out some WAV files, problem is it says that it uses a different encoder. Either that, or they're just borked...

Here's one of the audio files. There are 98 wav files so I presume that all of them are borked. https://drive.google.com/file/d/1_Z-VuL ... sp=sharing


Top
   
PostPosted: Tue Jul 21, 2020 11:54 am 

Joined: Fri Aug 08, 2014 11:25 am
Posts: 141
Games released on Xbox 360 / XBLA will almost always use the XMA codec which is why these files aren't playing. They're not PCM WAV, they're XMA.

Rename the extension to from '.wav' to '.xma' and use vgmstream to playback / convert the file by using running the test.exe in command prompt or use the winamp plugin.


Top
   
PostPosted: Wed Jul 22, 2020 7:10 am 

Joined: Fri Jan 11, 2019 12:23 pm
Posts: 9
brendan19 wrote:
Games released on Xbox 360 / XBLA will almost always use the XMA codec which is why these files aren't playing. They're not PCM WAV, they're XMA.

Rename the extension to from '.wav' to '.xma' and use vgmstream to playback / convert the file by using running the test.exe in command prompt or use the winamp plugin.

Solved! I got all of the sound assets now. Thank you!!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited