ZenHAX

Free Game Research Forum | Official QuickBMS support | twitter @zenhax | SSL HTTPS://zenhax.com
It is currently Sat Oct 31, 2020 9:26 am

All times are UTC




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Mar 18, 2019 9:16 pm 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 11701
Just made some reverse engineering and a script for extracting all the YPF files of NEKO-NIN, it's also compatible with older versions of the YU-RIS engine:
http://aluigi.org/bms/ysris_ypf.bms


Top
   
PostPosted: Fri Jul 03, 2020 4:17 pm 

Joined: Fri Jul 03, 2020 3:52 pm
Posts: 2
aluigi wrote:
Just made some reverse engineering and a script for extracting all the YPF files of NEKO-NIN, it's also compatible with older versions of the YU-RIS engine:
http://aluigi.org/bms/ysris_ypf.bms

Hey, aluigi. Your script and utility are awesome and really usefull, thx a lot.
But in some case your script worked not properly. I wanna make translation for NEKO-NIN exHeart and i try to unpack update1.ypf but after that names of files in "font" folder are broken. Just look at this mess Image
I tried to reimport them, but after that game starts crushing

And that's not all. There are only 77 files after using your script for BMS, but in archive they are 95.
This - how it's looks, if you used Garbro for unpacking
Image

Can you help me with this trouble, please? I really need this files with correct names, because without them i cant modify font and cant make my translation working.
I tried to use font files after unpack with Garbro but your utility wan't reimport them :(


Top
   
PostPosted: Sun Oct 11, 2020 4:45 pm 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 11701
Sure, upload one of the archives that gives that problem.


Top
   
PostPosted: Mon Oct 12, 2020 7:28 pm 

Joined: Fri Jul 03, 2020 3:52 pm
Posts: 2
aluigi wrote:
Sure, upload one of the archives that gives that problem.

Here. Its really huge for uploading on forum, so i used google drive
https://drive.google.com/file/d/1nveRTP ... sp=sharing


Top
   
PostPosted: Mon Oct 12, 2020 10:36 pm 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 11701
Ok the problem was just the codepage since it needed the japanese one (932) while default is utf8.
Fixed script.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited