ZenHAX

Free Game Research Forum | Official QuickBMS support | twitter @zenhax | SSL HTTPS://zenhax.com
It is currently Tue Apr 20, 2021 4:10 pm

All times are UTC




Post new topic  Reply to topic  [ 25 posts ]  Go to page Previous 1 2
Author Message
PostPosted: Sat Mar 27, 2021 8:58 am 
Site Admin
User avatar

Joined: Wed Jul 30, 2014 9:32 pm
Posts: 12096
Are you using the script 0.4.25?
Currently no idea about that error, the UE4 script should be quite stable even with the overhit workaround.


Top
   
PostPosted: Sat Mar 27, 2021 10:42 am 

Joined: Sat Sep 28, 2019 7:00 pm
Posts: 333
aluigi, the game is using two magics. With the previous script version it's omitting stuff through backward compatibility to the second magic, where workaround is applied. With the new approach it's trying to find magic in a different offset and find first one (typical for UE4 packages), which will not work. Forcing magic offset to 0x2C without future search should resolve this issue (and it was the last step for backward compatibility in previous script version).

Update: Sorry, magics are not identical, actually search function for magic offset is the culprit. At least for older game versions.

@CriticalError: Use "latest" script from here, it should work.

_________________
You can request AES keys on rin forums (the list with keys is also there)
AES keys finder and latest UE4 bms scripts: in this post


Last edited by spiritovod on Sun Mar 28, 2021 12:15 pm, edited 1 time in total.

Top
   
PostPosted: Sun Mar 28, 2021 12:45 am 
User avatar

Joined: Thu Aug 14, 2014 8:52 pm
Posts: 203
aluigi wrote:
Are you using the script 0.4.25?
Currently no idea about that error, the UE4 script should be quite stable even with the overhit workaround.
I use latest download from your web.

spiritovod wrote:
aluigi, the game is using two identical magics. With the previous script version it's omitting stuff through backward compatibility to the second magic, where workaround is applied. With the new approach it's trying to find magic upward and find first one, which will not work. Setting initial magic offset to 0x2C and then searching upward should resolve this issue, but it also may break other workarounds for similar reasons.

@CriticalError: Use "latest" script from here, it should work.


which one, attachment have a lot scripts and try with all and same error.

tested

latest_UE4_bms-script.bms with same result as screenshot posted.

unreal_tournament_4_0.4.26_paks_only.bms tested and got this error

offset filesize filename
--------------------------------------
The archive is encrypted, select the number of the key to use or type yours:
0: press RETURN for no encryption (Lineage 2 Revolution)

- please insert the content for the variable KEY:
0x4531413146324534414130363643353442443530393046343633454444463538
KEY: E1A1F2E4AA066C54BD5090F463EDDF58

Error: [myfseek] offset 0xe9bbed77286ed4e2 in file 0 can't be reached

Last script line before the error or that produced the error:
50 log MEMORY_FILE5 OFFSET SIZE

others are for others games.


Top
   
PostPosted: Sun Mar 28, 2021 12:28 pm 

Joined: Sat Sep 28, 2019 7:00 pm
Posts: 333
@CriticalError: This info is valid for last playmarket korean version, provided by RedBear in this topic. After it both global and korean playmarket versions were discontinued. If you're trying to extract more recent version of the game, you better provide sample pak for futher research.

And I've updated my previous post, because the reason why current aluigi's script doesn't work even with older game versions is a bit different. Sorry for misinformation.

_________________
You can request AES keys on rin forums (the list with keys is also there)
AES keys finder and latest UE4 bms scripts: in this post


Top
   
PostPosted: Mon Mar 29, 2021 12:48 am 
User avatar

Joined: Thu Aug 14, 2014 8:52 pm
Posts: 203
spiritovod wrote:
@CriticalError: This info is valid for last playmarket korean version, provided by RedBear in this topic. After it both global and korean playmarket versions were discontinued. If you're trying to extract more recent version of the game, you better provide sample pak for futher research.

And I've updated my previous post, because the reason why current aluigi's script doesn't work even with older game versions is a bit different. Sorry for misinformation.
well thanks for reply, after lot tests and try the script working with files are unreal_tournament_4_0.4.23.1a_sot.bms.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 25 posts ]  Go to page Previous 1 2

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited